Email Service Outage and/or Delay

Incident Report for Davidson College

Resolved

Microsoft has resolved the underlying issue behind this outage.
Posted Jan 23, 2026 - 08:12 EST

Update

We are continuing to investigate this issue.
Posted Jan 23, 2026 - 08:11 EST

Investigating

Davidson T&I is aware of an issue with Microsoft services that is affecting outgoing mail, in addition to other Microsoft services including OneDrive. Expect delays with mail services, in particular for emails to and from emails outside of the davidson.edu system. We are monitoring this situation and will provide updates as available.
Posted Jan 22, 2026 - 16:06 EST
This incident affected: Enterprise Applications (Microsoft 365).